Description
Consider the number triangle shown below. Write a program thatcalculates the highest sum of numbers that can be passed on a routethat starts at the top and ends somewhere on the base. Each stepcan go either diagonally down to the left or diagonally down to theright.
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
In the sample above, the route from 7 to 3 to 8 to 7 to 5produces the highest sum: 30.
Input
The first line contains R (1 <= R<= 1000), the number of rows. Each subsequent linecontains the integers for that particular row of the triangle. Allthe supplied integers are non-negative and no larger than 100.
Output
A single line containing the largest sum using the traversalspecified.
Sample Input
573 88 1 02 7 4 44 5 2 6 5
Sample Output
30
#include<iostream>
using namespace std;
int main()
{
intn,i,j;
cin>>n;
int **a=newint *[n];
for(i=0;i<n;i++)
a[i]=new int[i+1];
for(i=0;i<n;i++)
for(j=0;j<=i;j++)
cin>>a[i][j];
for(i=n-2;i>=0;i--)
for(j=0;j<=i;j++)//从下往上依次遍历!
a[i][j]+=(a[i+1][j]>a[i+1][j+1])?a[i+1][j]:a[i+1][j+1];
cout<<a[0][0]<<endl;
}